summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-11 12:20:05 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:10:04 +0200
commit20842b795e25273a5d75d5ee7e584cb12f5f8125 (patch)
treebf7ff0282381c842138ea6e48d93cf75c95e32db /gnu/packages/gtk.scm
parent3f03bd372871a95e2ebb50197172f7a95329feed (diff)
downloadguix-patches-20842b795e25273a5d75d5ee7e584cb12f5f8125.tar
guix-patches-20842b795e25273a5d75d5ee7e584cb12f5f8125.tar.gz
gnu: Add libdatrie.
* gnu/packages/gtk.scm (libdatrie): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 549de975cc..83a7490208 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -224,6 +225,35 @@ affine transformation (scale, rotation, shear, etc.).")
"See 'COPYING' in the distribution."))
(home-page "https://www.freedesktop.org/wiki/Software/HarfBuzz/")))
+(define-public libdatrie
+ (package
+ (name "libdatrie")
+ (version "0.2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://linux.thai.net/pub/ThaiLinux/software/"
+ "libthai/libdatrie-" version ".tar.xz"))
+ (sha256
+ (base32 "0jz9k0dd8jim4iyk5xrhkkdm4zq2ly6aw317ydjss44ymg97nz2l"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "--with-html-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/datrie/html"))))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Double-Array Trie Library")
+ (description "Libdatrie is an implementation of double-array structure for
+representing trie. Trie is a kind of digital search tree.")
+ (home-page "https://linux.thai.net/~thep/datrie/datrie.html")
+ (license license:lgpl2.1+)))
+
(define-public pango
(package
(name "pango")