summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 21:40:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 23:18:48 +0100
commit738923b6e3ac85c78b1e97a9a85979495ed8ba51 (patch)
tree78d2fd8b1c8ea2d3e0a15a71e73a46440f8dfc57 /gnu/packages/gstreamer.scm
parent9792adaa611e495ee1a53e5849a37fef7fa49edf (diff)
downloadguix-patches-738923b6e3ac85c78b1e97a9a85979495ed8ba51.tar
guix-patches-738923b6e3ac85c78b1e97a9a85979495ed8ba51.tar.gz
gnu: gst-plugins-base: Build with Meson.
* gnu/packages/gstreamer.scm (gst-plugins-base)[build-system]: Change to MESON-BUILD-SYSTEM. [outputs]: Remove. [arguments]: Enable parallel tests. Disable doc generation and Mesa dependency.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 126972fd1b..e78afdabb8 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -171,8 +171,7 @@ This package provides the core library and elements.")
(sha256
(base32
"0sl1hxlyq46r02k7z70v09vx1gi4rcypqmzra9jid93lzvi76gmi"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
+ (build-system meson-build-system)
(propagated-inputs
`(("glib" ,glib) ;required by gstreamer-sdp-1.0.pc
("gstreamer" ,gstreamer) ;required by gstreamer-plugins-base-1.0.pc
@@ -206,11 +205,10 @@ This package provides the core library and elements.")
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
+ '(#:configure-flags '("-Dgl=disabled"
+ ;; FIXME: Documentation fails to build without
+ ;; enabling GL above, which causes other problems.
+ "-Ddoc=false")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch