summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 21:38:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 23:18:48 +0100
commit9792adaa611e495ee1a53e5849a37fef7fa49edf (patch)
tree7ce34a013d4f4d29a494bfb133715fb87842ca1c /gnu/packages/gstreamer.scm
parent25b8d676c01bc9cd206a12bd2bdd767e47b4e693 (diff)
downloadguix-patches-9792adaa611e495ee1a53e5849a37fef7fa49edf.tar
guix-patches-9792adaa611e495ee1a53e5849a37fef7fa49edf.tar.gz
gnu: gstreamer: Build with Meson.
The package fails to build with GNU Make 4.3, and upstream no longer supports autotools. * gnu/packages/gstreamer.scm (gstreamer)[build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Remove #:configure-flags. Add #:phases. [native-inputs]: Add GTK-DOC.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 63b4179bc6..126972fd1b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -116,19 +116,27 @@ arrays of data.")
(sha256
(base32
"0kp93622y29pck8asvil1fmzf55s2gx76wv475a6izc3cwj49w73"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (copy-recursively (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ (delete-file-recursively (string-append out "/share/gtk-doc"))
+ #t))))))
(propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))