summaryrefslogtreecommitdiff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 17:55:38 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:37:14 +0200
commitdc51a0a8fd15c2a23495ea47ee06e0335f80f8a1 (patch)
tree68eed9fc1e794024d2019afcc81dd15fe87c6cd5 /gnu/packages/groovy.scm
parent2af51fd06774232922ce302e8617cf9573a96491 (diff)
downloadguix-patches-dc51a0a8fd15c2a23495ea47ee06e0335f80f8a1.tar
guix-patches-dc51a0a8fd15c2a23495ea47ee06e0335f80f8a1.tar.gz
gnu: Add groovy-testng.
* gnu/packages/groovy.scm (groovy-testng): New variable.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index 4d67010f0d..fd63c422c6 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -969,3 +969,42 @@ version of Java servlets.")))
(synopsis "Groovy SQL library")
(description "This package contains a facade over Java's normal JDBC APIs
providing greatly simplified resource management and result set handling.")))
+
+(define groovy-testng
+ (package
+ (inherit groovy-bootstrap)
+ (name "groovy-testng")
+ (arguments
+ `(#:jar-name "groovy-testng.jar"
+ #:tests? #f; No tests
+ #:jdk ,icedtea-8
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "subprojects/groovy-testng")
+ #t))
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes")
+ #t))
+ (replace 'build
+ (lambda _
+ (mkdir-p "build/classes")
+ (mkdir-p "build/jar")
+ (apply invoke "java" "-cp" (getenv "CLASSPATH")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/classes"
+ "-j"; joint compilation
+ (find-files "src/main" ".*\\.(groovy|java)$"))
+ (invoke "jar" "-cf" "build/jar/groovy-testng.jar"
+ "-C" "build/classes" ".")
+ #t)))))
+ (native-inputs
+ `(("groovy-bootstrap" ,groovy-bootstrap)
+ ("groovy-test" ,groovy-test)
+ ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+ ,@(package-native-inputs java-groovy-bootstrap)))
+ (synopsis "Groovy testing framework")
+ (description "This package contains integration code for running TestNG
+tests in Groovy.")))