summaryrefslogtreecommitdiff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 17:54:38 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:37:11 +0200
commit2af51fd06774232922ce302e8617cf9573a96491 (patch)
tree6be9614b83ef7dc4694676dc1a080d078c3bb10d /gnu/packages/groovy.scm
parent107ebf7b34e619de9f6b50996ede6c7c0e1159cb (diff)
downloadguix-patches-2af51fd06774232922ce302e8617cf9573a96491.tar
guix-patches-2af51fd06774232922ce302e8617cf9573a96491.tar.gz
gnu: Add groovy-sql.
* gnu/packages/groovy.scm (groovy-sql): New variable.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index 3f7c78a998..4d67010f0d 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -933,3 +933,39 @@ the functionality of the common library of Java.")))
(synopsis "Groovy's servlet implementation")
(description "This package contains a library to create groovlets, Groovy's
version of Java servlets.")))
+
+(define groovy-sql
+ (package
+ (inherit groovy-bootstrap)
+ (name "groovy-sql")
+ (arguments
+ `(#:jar-name "groovy-sql.jar"
+ #:test-dir "src/test"
+ #:tests? #f;TODO: Requires hsqldb
+ #:jdk ,icedtea-8
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "subprojects/groovy-sql")
+ #t))
+ (replace 'build
+ (lambda _
+ (mkdir-p "build/classes")
+ (mkdir-p "build/jar")
+ (apply invoke "java" "-cp" (getenv "CLASSPATH")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/classes" "-j"; joint compilation
+ (find-files "src/main"
+ ".*\\.(groovy|java)$"))
+ (invoke "jar" "-cf" "build/jar/groovy-sql.jar"
+ "-C" "build/classes" ".")
+ #t)))))
+ (native-inputs
+ `(("groovy-bootstrap" ,groovy-bootstrap)
+ ("groovy-test" ,groovy-test)
+ ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+ ,@(package-native-inputs java-groovy-bootstrap)))
+ (synopsis "Groovy SQL library")
+ (description "This package contains a facade over Java's normal JDBC APIs
+providing greatly simplified resource management and result set handling.")))