summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-06 10:54:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-06 11:14:53 +0200
commit3b141f2eb9939a0140e0e1cec8ef451a81d9e2dc (patch)
treeb5f6e3be2199e74b26478dc92e3553f0c06aa4fb /gnu/packages/gps.scm
parentd5ecfb491845aee1fb4079fc71d93ba00e4b10be (diff)
downloadguix-patches-3b141f2eb9939a0140e0e1cec8ef451a81d9e2dc.tar
guix-patches-3b141f2eb9939a0140e0e1cec8ef451a81d9e2dc.tar.gz
gnu: gpsbabel: Enable tests.
* gnu/packages/patches/gps.scm (gpsbabel)[source]: Add patch. [arguments]: Enable tests. * gnu/packages/patches/gpsbabel-fix-i686-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 7ee1fc871d..4fa3bcef19 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -65,6 +65,7 @@
(sha256
(base32
"010g0vd2f5knpq5p7qfnl31kv3r8m5sjdsafcinbj5gh02j2nzpy"))
+ (patches (search-patches "gpsbabel-fix-i686-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -80,13 +81,7 @@
;; TODO: "make doc" requires Docbook & co.
(arguments
`(#:configure-flags
- '("--with-zlib=system")
- ;; On i686, 'raymarine.test' fails because of a rounding error:
- ;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
- ;; on these platforms.
- ;; FIXME: On x86_64 with -std=gnu++11 tests also fail due to rounding
- ;; error.
- #:tests? #f))
+ '("--with-zlib=system")))
(inputs
`(("expat" ,expat)
("libusb" ,libusb)