summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-06 10:40:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-06 11:14:53 +0200
commitd5ecfb491845aee1fb4079fc71d93ba00e4b10be (patch)
treede6ab0049d2ce3eda3e3143029da8f000939873a /gnu/packages/gps.scm
parentf024a7ba604fb18721a056e65777ae969d8b9681 (diff)
downloadguix-patches-d5ecfb491845aee1fb4079fc71d93ba00e4b10be.tar
guix-patches-d5ecfb491845aee1fb4079fc71d93ba00e4b10be.tar.gz
gnu: gpsbabel: Unbundle zlib.
* gnu/packages/gps.scm (gpsbabel)[source]: Adjust snippet to remove bundled zlib and references from the Makefile.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index fdb64f0902..7ee1fc871d 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +68,9 @@
(modules '((guix build utils)))
(snippet
'(begin
+ (delete-file-recursively "zlib")
+ (substitute* "Makefile.in"
+ ((" zlib/z.*\\.h") ""))
;; Delete files under GPL-compatible licences but never used
;; on GNU systems, rather than bloating the LICENSE field.
(delete-file "gui/serial_mac.cc") ; Apple MIT