summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:07:24 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:19 +0300
commitfc8d9df75fc826c76b3d3b068d1d8b8aabb4d51d (patch)
tree66f2aa50af171d9897547b9cacf9aeaeccbbc16c /gnu/packages/golang.scm
parent1a1463c20ea74e69ee068e6565c72d645be798d4 (diff)
downloadguix-patches-fc8d9df75fc826c76b3d3b068d1d8b8aabb4d51d.tar
guix-patches-fc8d9df75fc826c76b3d3b068d1d8b8aabb4d51d.tar.gz
gnu: Add go-github-com-puerkitobio-goquery.
* gnu/packages/golang.scm (go-github-com-puerkitobio-goquery): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f473f4cd76..4192bd176e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4687,3 +4687,28 @@ converts it into syntax highlighted HTML, ANSI-coloured text, etc.")
(description "The Cascadia package implements CSS selectors for use with
the parse trees produced by the html package.")
(license license:bsd-2)))
+
+(define-public go-github-com-puerkitobio-goquery
+ (package
+ (name "go-github-com-puerkitobio-goquery")
+ (version "1.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PuerkitoBio/goquery")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08nf88cg663slzqr51k2jxlm1krnh86nrzwbk6v41ccq5jkfm7fx"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/PuerkitoBio/goquery"))
+ (native-inputs
+ `(("go-github-com-andybalholm-cascadia" ,go-github-com-andybalholm-cascadia)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)))
+ (home-page "https://github.com/PuerkitoBio/goquery")
+ (synopsis "Features similar to jQuery to the Go language")
+ (description "@code{goquery} brings a syntax and a set of features similar
+to jQuery to the Go language.")
+ (license license:bsd-3)))