summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:06:40 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:19 +0300
commit1a1463c20ea74e69ee068e6565c72d645be798d4 (patch)
treee69f96f545bb183dc85a3af3f487b961fe5637f4 /gnu/packages/golang.scm
parentf12cca097b3debac95545ef4cfc7626927267cc1 (diff)
downloadguix-patches-1a1463c20ea74e69ee068e6565c72d645be798d4.tar
guix-patches-1a1463c20ea74e69ee068e6565c72d645be798d4.tar.gz
gnu: Add go-github-com-andybalholm-cascadia.
* gnu/packages/golang.scm (go-github-com-andybalholm-cascadia): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7847795710..f473f4cd76 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4663,3 +4663,27 @@ synchronizing plain text:
(description "Chroma takes source code and other structured text and
converts it into syntax highlighted HTML, ANSI-coloured text, etc.")
(license license:expat)))
+
+(define-public go-github-com-andybalholm-cascadia
+ (package
+ (name "go-github-com-andybalholm-cascadia")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andybalholm/cascadia")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09j8cavbhqqdxjqrkwbc40g8p0i49zf3184rpjm5p2rjbprcghcc"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/andybalholm/cascadia"))
+ (native-inputs
+ `(("go-golang-org-x-net" ,go-golang-org-x-net)))
+ (home-page "https://github.com/andybalholm/cascadia/")
+ (synopsis "CSS selectors for HTML")
+ (description "The Cascadia package implements CSS selectors for use with
+the parse trees produced by the html package.")
+ (license license:bsd-2)))