summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHiPhish <hiphish@posteo.de>2020-09-13 11:04:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-10-04 11:03:58 +0300
commite8fd351e8f8a58e579e4db857df0a73336b536ed (patch)
tree6c3591ccb9f481a33a41138bd22fb009bd1ecbc1 /gnu/packages/golang.scm
parente35870525fd56491a2d024d04335e1a371f98381 (diff)
downloadguix-patches-e8fd351e8f8a58e579e4db857df0a73336b536ed.tar
guix-patches-e8fd351e8f8a58e579e4db857df0a73336b536ed.tar.gz
gnu: Add go-github-com-saracen-walker.
* gnu/packages/golang.scm (go-github-com-saracen-walker): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e33ccfcfc3..42e65b3345 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -559,6 +559,30 @@ per-goroutine.")
(home-page "https://github.com/jtolds/gls")
(license license:expat)))
+(define-public go-github-com-saracen-walker
+ (package
+ (name "go-github-com-saracen-walker")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/saracen/walker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rq1lrp99lx7k1ysbfznn4c1iagnxdhb4lnnklsadnnzi3gvygqz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/saracen/walker"))
+ (inputs
+ `(("go-golang-org-x-sync" ,go-golang-org-x-sync)))
+ (home-page "https://github.com/saracen/walker")
+ (synopsis "Faster, parallel version of Go's filepath.Walk")
+ (license license:expat)
+ (description "The @code{walker} function is a faster, parallel version, of
+@code{filepath.Walk}")))
+
(define-public go-github-com-tj-docopt
(package
(name "go-github-com-tj-docopt")