summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHiPhish <hiphish@posteo.de>2020-09-13 11:02:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-10-04 11:03:29 +0300
commite35870525fd56491a2d024d04335e1a371f98381 (patch)
tree7d61327f7330909f7f43abc7f3a26711380ea9f2 /gnu/packages/golang.scm
parentcdcbb42aa398f697dfe86563b98bddc3cb3d525a (diff)
downloadguix-patches-e35870525fd56491a2d024d04335e1a371f98381.tar
guix-patches-e35870525fd56491a2d024d04335e1a371f98381.tar.gz
gnu: Add go-golang-org-x-sync.
* gnu/packages/golang.scm (go-golang-org-x-sync): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 001c864505..e33ccfcfc3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -741,6 +741,36 @@ for the Go language.")
processing.")
(license license:bsd-3))))
+(define-public go-golang-org-x-sync
+ (let ((commit "6e8e738ad208923de99951fe0b48239bfd864f28")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-sync")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/sync")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1avk27pszd5l5df6ff7j78wgla46ir1hhy2jwfl9a3c0ys602yx9"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/sync"
+ #:tests? #f
+ ;; Source-only package
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (synopsis "Additional Go concurrency primitives")
+ (description "This package provides Go concurrency primitives in addition
+to the ones provided by the language and “sync” and “sync/atomic”
+packages.")
+ (home-page "https://go.googlesource.com/sync/")
+ (license license:bsd-3))))
+
(define-public go-golang-org-x-sys
(let ((commit "c709ea063b76879dc9915358f55d4d77c16ab6d5")
(revision "6"))