summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-11-19 18:06:33 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:11:51 +0100
commitda4b02ad3f79848b47d707c08bbf94b0ff41e702 (patch)
treef04eafd017933a7abd44227fc22be6829e28e671 /gnu/packages/golang.scm
parent0a15bc03971b1617b981eca9cb3c220d9f49beb0 (diff)
downloadguix-patches-da4b02ad3f79848b47d707c08bbf94b0ff41e702.tar
guix-patches-da4b02ad3f79848b47d707c08bbf94b0ff41e702.tar.gz
gnu: Add go-github-com-alecthomas-units
* gnu/packages/golang.scm (go-github-com-alecthomas-units): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ef864f25d3..add69bf599 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9098,3 +9098,29 @@ newlines until a non-newline.")
(home-page "https://github.com/alecthomas/template")
(license license:bsd-3))))
+(define-public go-github-com-alecthomas-units
+ (let ((commit "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a")
+ (revision "0"))
+ (package
+ (name "go-github-com-alecthomas-units")
+ (version "0.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/units")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j65b91qb9sbrml9cpabfrcf07wmgzzghrl7809hjjhrmbzri5bl"))))
+ (build-system go-build-system)
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (arguments
+ '(#:import-path "github.com/alecthomas/units"
+ #:phases %standard-phases))
+ (synopsis "Helpful unit multipliers and functions for Go")
+ (description
+ "This library provides unit multipliers and functions for Go.")
+ (home-page "https://github.com/alecthomas/units")
+ (license license:expat))))