summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-11-19 18:06:02 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:11:51 +0100
commit0a15bc03971b1617b981eca9cb3c220d9f49beb0 (patch)
treec4f2fdb017b08e1e7c513444fff46d6127a88b19 /gnu/packages/golang.scm
parentde69f20f628a8e9b57ef0f0e98d7687154eb12ba (diff)
downloadguix-patches-0a15bc03971b1617b981eca9cb3c220d9f49beb0.tar
guix-patches-0a15bc03971b1617b981eca9cb3c220d9f49beb0.tar.gz
gnu: Add go-github-com-alecthomas-template
* gnu/packages/golang.scm (go-github-com-alecthomas-template): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0e86d4a463..ef864f25d3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9071,3 +9071,30 @@ GNU/Linux, this is a proxy for the @command{xdg-open} command.")
(home-page "https://github.com/skratchdot/open-golang")
(license license:expat))))
+(define-public go-github-com-alecthomas-template
+ (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
+ (revision "0"))
+ (package
+ (name "go-github-com-alecthomas-template")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/template")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/alecthomas/template"
+ #:phases %standard-phases))
+ (synopsis "Fork of Go's text/template adding newline elision")
+ (description
+ "This is a fork of Go 1.4's text/template package with one addition: a
+backslash immediately after a closing delimiter will delete all subsequent
+newlines until a non-newline.")
+ (home-page "https://github.com/alecthomas/template")
+ (license license:bsd-3))))
+