summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 15:51:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:25 +0300
commitae110203569647b5dd6230c9c9f9af864da45374 (patch)
tree9883ab636972616bc262d3d1a09ce4363b573f1f /gnu/packages/golang.scm
parentfb1cc65af1dc4ab131cf3a9ad223dd24c3ede376 (diff)
downloadguix-patches-ae110203569647b5dd6230c9c9f9af864da45374.tar
guix-patches-ae110203569647b5dd6230c9c9f9af864da45374.tar.gz
gnu: Add go-github-com-twpayne-go-vfs.
* gnu/packages/golang.scm (go-github-com-twpayne-go-vfs): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e991e370c8..b76a71abef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5410,3 +5410,27 @@ temporal directories.")
(description
"Package @code{shell} returns a user's shell across multiple platforms.")
(license license:expat)))
+
+(define-public go-github-com-twpayne-go-vfs
+ (package
+ (name "go-github-com-twpayne-go-vfs")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-vfs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19dm3gi45znwaqbzxhwcgkiz8059bwa3ank80hc6qhdl579bpjnz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/twpayne/go-vfs"))
+ (native-inputs
+ `(("go-github-com-bmatcuk-doublestar" ,go-github-com-bmatcuk-doublestar)))
+ (home-page "https://github.com/twpayne/go-vfs/")
+ (synopsis "Abstraction of the @code{os} and @code{ioutil} Go packages")
+ (description "Package @code{vfs} provides an abstraction of the @code{os}
+and @code{ioutil} packages that is easy to test.")
+ (license license:expat)))