summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 15:48:36 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:25 +0300
commitfb1cc65af1dc4ab131cf3a9ad223dd24c3ede376 (patch)
tree3e94eb508f32161663bffd66ee3ebd125d0459d2 /gnu/packages/golang.scm
parent55ce6fe9b88b071e2ceffd744bb4470d175cb647 (diff)
downloadguix-patches-fb1cc65af1dc4ab131cf3a9ad223dd24c3ede376.tar
guix-patches-fb1cc65af1dc4ab131cf3a9ad223dd24c3ede376.tar.gz
gnu: Add go-github-com-twpayne-go-shell.
* gnu/packages/golang.scm (go-github-com-twpayne-go-shell): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c767ed6e39..e991e370c8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5388,3 +5388,25 @@ temporal directories.")
(description
"This package provides a Go library to create and print diffs.")
(license license:bsd-3))))
+
+(define-public go-github-com-twpayne-go-shell
+ (package
+ (name "go-github-com-twpayne-go-shell")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-shell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hv0ggy3935iddjnmpp9vl0kqjknxpnbmm9w7xr3gds7fpbxz6yp"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/twpayne/go-shell"))
+ (home-page "https://github.com/twpayne/go-shell/")
+ (synopsis "Shell across multiple platforms")
+ (description
+ "Package @code{shell} returns a user's shell across multiple platforms.")
+ (license license:expat)))