summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 21:27:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:11 +0300
commit54da48e2cea47b230f9306dcb33e41dfa934a84e (patch)
treebedc805f05461782c716da35e6611de99e8de3e1 /gnu/packages/golang.scm
parent25494265b28d0121e9d1e12113fd64d9dcefe8f7 (diff)
downloadguix-patches-54da48e2cea47b230f9306dcb33e41dfa934a84e.tar
guix-patches-54da48e2cea47b230f9306dcb33e41dfa934a84e.tar.gz
gnu: go-github.com-jtolds-gls: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github.com-ktolds-gls)[arguments]: Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 29812d48ef..98338cb701 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2439,7 +2439,16 @@ termination.")
"1k7xd2q2ysv2xsh373qs801v6f359240kx0vrl0ydh7731lngvk6"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/jtolds/gls"))
+ (list
+ #:import-path "github.com/jtolds/gls"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(synopsis "@code{gls} provides Goroutine local storage")
(description
"The @code{gls} package provides a way to store a retrieve values