summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 21:19:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:08 +0300
commit25494265b28d0121e9d1e12113fd64d9dcefe8f7 (patch)
treef9a17c548b122b0dacdcefb6044cf019d0d7ab62 /gnu/packages/golang.scm
parentb0c9f0324865a8bacd83c4c1db369209968e9f8a (diff)
downloadguix-patches-25494265b28d0121e9d1e12113fd64d9dcefe8f7.tar
guix-patches-25494265b28d0121e9d1e12113fd64d9dcefe8f7.tar.gz
gnu: go-github-com-pkg-errors: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github-com-pkg-errors)[arguments]: Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d2f3dc39df..29812d48ef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -54,6 +54,7 @@
(define-module (gnu packages golang)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (guix memoization)
#:use-module ((guix build utils) #:select (alist-replace))
#:use-module (guix download)
@@ -6017,7 +6018,16 @@ decode/encode structures and slices.")
"1761pybhc2kqr6v5fm8faj08x9bql8427yqg6vnfv6nhrasx1mwq"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/pkg/errors"))
+ (list
+ #:import-path "github.com/pkg/errors"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(synopsis "Go error handling primitives")
(description "This package provides @code{error}, which offers simple
error handling primitives in Go.")