summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 22:24:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:13 +0300
commit1d49fd4fab2396fc92bf9930875947ce79a27610 (patch)
tree034789b24816c926daef671de498ad13cd993a84 /gnu/packages/golang.scm
parent23e03dd087240a8dc39a2568f1b2576ed9bfba67 (diff)
downloadguix-patches-1d49fd4fab2396fc92bf9930875947ce79a27610.tar
guix-patches-1d49fd4fab2396fc92bf9930875947ce79a27610.tar.gz
gnu: go-github-com-stretchr-objx: Skip tests with gccgo.
* gnu/packages/golang.scm (go-github-com-stretchr-objx)[arguments]: Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8b343890aa..537722f164 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3026,7 +3026,16 @@ Go.")
(delete-file-recursively "vendor")))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/stretchr/objx"))
+ (list
+ #:import-path "github.com/stretchr/objx"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(propagated-inputs
(list go-github-com-davecgh-go-spew
go-github-com-pmezard-go-difflib))