summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8b343890aa..537722f164 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3026,7 +3026,16 @@ Go.")
(delete-file-recursively "vendor")))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/stretchr/objx"))
+ (list
+ #:import-path "github.com/stretchr/objx"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(propagated-inputs
(list go-github-com-davecgh-go-spew
go-github-com-pmezard-go-difflib))