summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-19 11:51:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-19 11:51:56 +0300
commite379d85c6c5a915c4ae27a42f5fd7d30fab9332e (patch)
tree78dd11405fc33fa15f282fb5e5407a2466fb5e22 /gnu/packages/gnupg.scm
parent7ac534037b2cd1433489aa49be5781944bdf2ced (diff)
downloadguix-patches-e379d85c6c5a915c4ae27a42f5fd7d30fab9332e.tar
guix-patches-e379d85c6c5a915c4ae27a42f5fd7d30fab9332e.tar.gz
gnu: paperkey: Use 'modify-phases'.
* gnu/packages/gnupg.scm (paperkey)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 1bb6c638ef..7df96b4796 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -668,13 +668,13 @@ passphrase when @code{gpg} or @code{gpg2} is run and needs it.")))
(build-system gnu-build-system)
(arguments
`(#:phases
- (alist-cons-before
- 'check 'patch-check-scripts
- (lambda _
- (substitute* '("checks/roundtrip.sh"
- "checks/roundtrip-raw.sh")
- (("/bin/echo") "echo")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-check-scripts
+ (lambda _
+ (substitute* '("checks/roundtrip.sh"
+ "checks/roundtrip-raw.sh")
+ (("/bin/echo") "echo"))
+ #t)))))
(home-page "http://www.jabberwocky.com/software/paperkey/")
(synopsis "Backup OpenPGP keys to paper")
(description