summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-08 01:56:53 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-08 12:32:17 -0700
commitba7bd6c62ddaab4d5623fb149b47579e13a9e5f5 (patch)
treee9be86811c8829403bc75451a0f5e0fe6d7b6923 /gnu/packages/gnupg.scm
parent97f6004ca194a764bc7829f1ebdc292ef01f9b2b (diff)
downloadguix-patches-ba7bd6c62ddaab4d5623fb149b47579e13a9e5f5.tar
guix-patches-ba7bd6c62ddaab4d5623fb149b47579e13a9e5f5.tar.gz
gnu: Add pgpdump.
* gnu/packages/gnupg (pgpdump): New variable. * gnu/packages/package-management (diffoscope)[native-inputs]: Add pgpdump.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 0d619c6a1d..bc1e3c8720 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -907,6 +907,34 @@ bytes (whether by hand, OCR, QR code, or the like) and paperkey can use
them to transform your existing public key into a secret key.")
(license license:gpl2+)))
+(define-public pgpdump
+ (package
+ (name "pgpdump")
+ (version "0.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.mew.org/~kazu/proj/pgpdump/pgpdump-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1j001jra2m89n6cys3n0hs574bipjdzfxhzpnd4jfyv95mqwl7n4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no make check
+ #:configure-flags (list "--prefix=/")
+ #:make-flags (list "CC=gcc"
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://www.mew.org/~kazu/proj/pgpdump/en/")
+ (synopsis "PGP packet visualizer")
+ (description "pgpdump displays the sequence of OpenPGP or PGP version 2
+packets from a file.
+
+The output of this command is similar to GnuPG's list packets command,
+however, pgpdump produces more detailed and easier to understand output.")
+ (license license:bsd-3)))
+
(define-public gpa
(package
(name "gpa")