summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnupg.scm28
-rw-r--r--gnu/packages/package-management.scm1
2 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 0d619c6a1d..bc1e3c8720 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -907,6 +907,34 @@ bytes (whether by hand, OCR, QR code, or the like) and paperkey can use
them to transform your existing public key into a secret key.")
(license license:gpl2+)))
+(define-public pgpdump
+ (package
+ (name "pgpdump")
+ (version "0.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.mew.org/~kazu/proj/pgpdump/pgpdump-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1j001jra2m89n6cys3n0hs574bipjdzfxhzpnd4jfyv95mqwl7n4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no make check
+ #:configure-flags (list "--prefix=/")
+ #:make-flags (list "CC=gcc"
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://www.mew.org/~kazu/proj/pgpdump/en/")
+ (synopsis "PGP packet visualizer")
+ (description "pgpdump displays the sequence of OpenPGP or PGP version 2
+packets from a file.
+
+The output of this command is similar to GnuPG's list packets command,
+however, pgpdump produces more detailed and easier to understand output.")
+ (license license:bsd-3)))
+
(define-public gpa
(package
(name "gpa")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 32836331f6..0d1830c164 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -659,6 +659,7 @@ transactions from C or Python.")
;; no unversioned openjdk available
("openjdk:jdk" ,openjdk12 "jdk")
("openssh" ,openssh)
+ ("pgpdump" ,pgpdump)
("poppler" ,poppler)
("rpm" ,rpm)
("sng" ,sng)