summaryrefslogtreecommitdiff
path: root/gnu/packages/gnucash.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-03 18:28:56 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-23 07:46:27 -0500
commita2e7e95663d11a1059fa900b4640e8ab75df627f (patch)
treef59909873ab3f1729e4e5682a47b82d6ede43976 /gnu/packages/gnucash.scm
parent7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3 (diff)
downloadguix-patches-a2e7e95663d11a1059fa900b4640e8ab75df627f.tar
guix-patches-a2e7e95663d11a1059fa900b4640e8ab75df627f.tar.gz
gnu: gnucash: Disable the stress-options-test using a phase.
The qof test is also reinstated; it was failing because the needed locales were not installed. * gnu/packages/patches/gnucash-disable-failing-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/gnucash.scm (gnucash)[patches]: Remove it. [phases]{disable-stress-options-test}: Implement it using SUBSTITUTES*. {install-locales}: New phase.
Diffstat (limited to 'gnu/packages/gnucash.scm')
-rw-r--r--gnu/packages/gnucash.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 015e2b0459..58b46243a2 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -60,8 +60,7 @@
(sha256
(base32
"0grr5qi5rn1xvr7qx5d7mcxa2mcgycy2b325ry73bb485a6yv5l3"))
- (patches (search-patches "gnucash-disable-failing-tests.patch"
- "gnucash-fix-test-transaction-failure.patch"))))
+ (patches (search-patches "gnucash-fix-test-transaction-failure.patch"))))
(build-system cmake-build-system)
(inputs
`(("guile" ,guile-2.2)
@@ -125,6 +124,21 @@
(substitute* "libgnucash/scm/price-quotes.scm"
(("\"perl\" \"-w\" ") ""))
#t))
+ ;; The test-stress-options unit test is known to fail, so we disable
+ ;; it (see: https://bugs.gnucash.org/show_bug.cgi?id=796877).
+ (add-after 'unpack 'disable-stress-options-test
+ (lambda _
+ (substitute* "gnucash/report/standard-reports/test/CMakeLists.txt"
+ (("test-stress-options.scm") ""))
+ #t))
+ ;; The qof test requires the en_US, en_GB, and fr_FR locales.
+ (add-before 'check 'install-locales
+ (lambda _
+ (setenv "LOCPATH" (getcwd))
+ (invoke "localedef" "-i" "en_US" "-f" "UTF-8" "./en_US.UTF-8")
+ (invoke "localedef" "-i" "en_GB" "-f" "UTF-8" "./en_GB.UTF-8")
+ (invoke "localedef" "-i" "fr_FR" "-f" "UTF-8" "./fr_FR.UTF-8")
+ #t))
;; There are about 100 megabytes of documentation.
(add-after 'install 'install-docs
(lambda* (#:key inputs outputs #:allow-other-keys)