summaryrefslogtreecommitdiff
path: root/gnu/packages/gnucash.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-03 18:07:16 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-23 07:46:27 -0500
commit7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3 (patch)
tree2dcb4fc2ac73de12639f61d030660eb165e137de /gnu/packages/gnucash.scm
parent20626f62c41c7787ab50d21e961de857f6616d81 (diff)
downloadguix-patches-7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3.tar
guix-patches-7c8ea31ac94f5b55f2f4bbc16264b987cb9556e3.tar.gz
gnu: gnucash: Convert price-quotes-perl patch to a phase.
* gnu/packages/patches/gnucash-price-quotes-perl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/gnucash.scm (gnucash)[patches]: Remove it. [phases]{fix-finance-quote-check}: Implement it using SUBSTITUTES*.
Diffstat (limited to 'gnu/packages/gnucash.scm')
-rw-r--r--gnu/packages/gnucash.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index e85a538c46..015e2b0459 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -60,8 +60,7 @@
(sha256
(base32
"0grr5qi5rn1xvr7qx5d7mcxa2mcgycy2b325ry73bb485a6yv5l3"))
- (patches (search-patches "gnucash-price-quotes-perl.patch"
- "gnucash-disable-failing-tests.patch"
+ (patches (search-patches "gnucash-disable-failing-tests.patch"
"gnucash-fix-test-transaction-failure.patch"))))
(build-system cmake-build-system)
(inputs
@@ -119,6 +118,13 @@
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))
#t)))
+ ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
+ ;; execute them with perl, so execute them directly instead.
+ (add-after 'unpack 'fix-finance-quote-check
+ (lambda _
+ (substitute* "libgnucash/scm/price-quotes.scm"
+ (("\"perl\" \"-w\" ") ""))
+ #t))
;; There are about 100 megabytes of documentation.
(add-after 'install 'install-docs
(lambda* (#:key inputs outputs #:allow-other-keys)