summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 18:48:17 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:56 -0400
commitc576328d77aaecb8fe4c0c2065b72df6471d900b (patch)
tree649edafd6f2327466d084711c5bc9a46bc4d5c88 /gnu/packages/gnome.scm
parent201547590de0bfd08acbe1f39adecbaa582778af (diff)
downloadguix-patches-c576328d77aaecb8fe4c0c2065b72df6471d900b.tar
guix-patches-c576328d77aaecb8fe4c0c2065b72df6471d900b.tar.gz
gnu: gnome-control-center: Update to 3.34.2.
* gnu/packages/gnome.scm (gnome-control-center): Update to 3.34.2. [arguments]: Add 'skip-gtk-update-icon-cache' phase. [native-inputs]: Remove gtk+:bin. (cherry picked from commit 093ab99e4f2d5b10ea604cfb469e47f19b187401)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 668e2a5259..187fe01ea5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6985,7 +6985,7 @@ devices using the GNOME desktop.")
(define-public gnome-control-center
(package
(name "gnome-control-center")
- (version "3.32.2")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6993,7 +6993,7 @@ devices using the GNOME desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "03np0mhfl9kkdw4cb711pda0cli9zgh2bq2gqn2zwbdi3qnhk9gs"))))
+ "054igagvmyzpaa5nwzz98gv7bk7l5dwp6g813707132si3szlpx8"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -7034,10 +7034,15 @@ devices using the GNOME desktop.")
(("DATADIR \"/gnome/gnome-version.xml\"")
(string-append "\"" gnome-desktop
"/share/gnome/gnome-version.xml\"")))
- #t))))))
+ #t)))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))
+ #t)))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
- ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("xsltproc" ,libxslt)