summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-17 16:59:37 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:56 -0400
commit201547590de0bfd08acbe1f39adecbaa582778af (patch)
tree229dc6d800e389e3edfd2995d86917e42c78ad2a /gnu/packages/gnome.scm
parentf67ce0069ad65dc6a811d14a3a86a2fe344097b3 (diff)
downloadguix-patches-201547590de0bfd08acbe1f39adecbaa582778af.tar
guix-patches-201547590de0bfd08acbe1f39adecbaa582778af.tar.gz
gnu: gnome-settings-daemon: Update to 3.34.1.
* gnu/packages/gnome.scm (gnome-settings-daemon): Update to 3.34.1. [arguments]: Add configure flag to build without systemd. [inputs]: Add gcr and modem-manager. (cherry picked from commit 048875f365d1591ad45853e76bda180d32f2bef7)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 00a8b00e2e..668e2a5259 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4192,7 +4192,7 @@ services for numerous locations.")
(define-public gnome-settings-daemon
(package
(name "gnome-settings-daemon")
- (version "3.32.1")
+ (version "3.34.1")
(source
(origin
(method url-fetch)
@@ -4201,7 +4201,7 @@ services for numerous locations.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02d0s0g2mmqfib44r3sf0499r08p61s8l2ndsjssbam1bi7x2dks"))))
+ "07y1gbicz0pbxmdgwrdzyc4byy30wfwpbqgvnx27gnpqmc5s50cr"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -4209,6 +4209,7 @@ services for numerous locations.")
(list (string-append "-Dudev_dir="
(assoc-ref %outputs "out")
"/lib/udev/rules.d/")
+ "-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref %outputs "out")
@@ -4246,7 +4247,9 @@ services for numerous locations.")
("librsvg" ,librsvg)
("xf86-input-wacom" ,xf86-input-wacom)
("wayland" ,wayland)
- ("network-manager" ,network-manager)))
+ ("network-manager" ,network-manager)
+ ("gcr" ,gcr)
+ ("modem-manager" ,modem-manager)))
(home-page "https://www.gnome.org")
(synopsis "GNOME settings daemon")
(description