summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-23 11:03:33 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:30 -0400
commit27dd1d76b26e633507679116b9d0bdad77f0ab47 (patch)
tree1daa242c3b2cde64510e0ea7f39d6e3108ac251f /gnu/packages/gnome.scm
parentfeee5ff5e83d31ef361840f200ecc1d57666358d (diff)
downloadguix-patches-27dd1d76b26e633507679116b9d0bdad77f0ab47.tar
guix-patches-27dd1d76b26e633507679116b9d0bdad77f0ab47.tar.gz
gnu: gnome-calendar: Update to 3.34.2.
* gnu/packages/gnome.scm (gnome-calendar): Update to 3.34.2. [arguments]: Add phase to skip gtk-update-icon-cache. [native-inputs]: Remove gtk+:bin. (cherry picked from commit 2f7f0be50c267a55624ac27b44542aebfffdad5e)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0b82161a57..3f3ef21058 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8011,7 +8011,7 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
(define-public gnome-calendar
(package
(name "gnome-calendar")
- (version "3.32.2")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -8019,17 +8019,24 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
name "-" version ".tar.xz"))
(sha256
(base32
- "07p73cvzj8idr80npja5yiv9pjfyi6qqfhaz5jwcgqspqbnhnl7k"))))
+ "1bnmd191044zn2kr6f5vg7sm5q59qf7z652awll1f7s6ahijr8rw"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
;; gnome-calendar has to be installed before the tests can be run
;; https://bugzilla.gnome.org/show_bug.cgi?id=788224
- #:tests? #f))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib-bin" ,glib "bin") ; For glib-compile-schemas
- ("gtk+-bin" ,gtk+ "bin") ; For gtk-update-icon-cache
("pkg-config" ,pkg-config)))
(inputs
`(("evolution-data-server" ,evolution-data-server)