summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-23 10:51:44 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:30 -0400
commitfeee5ff5e83d31ef361840f200ecc1d57666358d (patch)
treedebff76c51c55533c6c5705afe363b2aeef5a0c9 /gnu/packages/gnome.scm
parent18364fbc30f505aa744141f24478f20e82234620 (diff)
downloadguix-patches-feee5ff5e83d31ef361840f200ecc1d57666358d.tar
guix-patches-feee5ff5e83d31ef361840f200ecc1d57666358d.tar.gz
gnu: gnome-clocks: Update to 3.34.0.
* gnu/packages/gnome.scm (gnome-clocks): Update to 3.34.0. [arguments]: Add phase to skip gtk-update-icon-cache. [native-inputs]: Remove gtk+:bin. (cherry picked from commit 0293a06e5524ca9e894f111f68c1c9e7b6263810)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 948fffaf5d..0b82161a57 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7966,7 +7966,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
(define-public gnome-clocks
(package
(name "gnome-clocks")
- (version "3.32.0")
+ (version "3.34.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7974,15 +7974,22 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1w6lgjdak3x76c9gyhd1lqrdmjfh8q77sjnrkcimylsg0jq913bc"))))
+ "0g7hjk55smhkd09hwa9kag3h5a12l494wj89w9smpdk3ghsmy6b1"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t))
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/post-install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))))
(native-inputs
`(("vala" ,vala)
("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; for glib-compile-resources
- ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("desktop-file-utils" ,desktop-file-utils)
("gettext" ,gettext-minimal)
("itstool" ,itstool)))