summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-03 00:16:38 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-07 19:34:31 +0100
commit579a5eff08e62b33ade5b57b4098b735a7860583 (patch)
treecb0f0a56dd8d40f8639ea7b6ad563dee3229df22 /gnu/packages/gnome-xyz.scm
parent43c8b56f72e03ec041238283d05b8d533bc40723 (diff)
downloadguix-patches-579a5eff08e62b33ade5b57b4098b735a7860583.tar
guix-patches-579a5eff08e62b33ade5b57b4098b735a7860583.tar.gz
gnu: gnome-xyz.scm: Reorder packages.
Make it so that icon themes, shell extensions and GTK themes are grouped in that order. * gnu/packages/gnome-xyz.scm (matcha-theme): Move before numix-gtk-theme. (papirus-icon-theme): Move after moka-icon-theme.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm154
1 files changed, 77 insertions, 77 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0c76c6320d..a0e31bc15c 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -50,52 +50,6 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xml))
-(define-public matcha-theme
- (package
- (name "matcha-theme")
- (version "2021-01-01")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/vinceliuice/Matcha-gtk-theme")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pa6ra87wlq0gwz4n03l6xv0pxiamr5dygycvppms8v6xyc2aa0r"))))
- (build-system trivial-build-system)
- (arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((out (assoc-ref %outputs "out"))
- (source (assoc-ref %build-inputs "source"))
- (bash (assoc-ref %build-inputs "bash"))
- (coreutils (assoc-ref %build-inputs "coreutils"))
- (themesdir (string-append out "/share/themes")))
- (setenv "PATH"
- (string-append coreutils "/bin:"
- (string-append bash "/bin:")))
- (copy-recursively source (getcwd))
- (patch-shebang "install.sh")
- (mkdir-p themesdir)
- (invoke "./install.sh" "-d" themesdir)
- #t))))
- (inputs
- `(("gtk-engines" ,gtk-engines)))
- (native-inputs
- `(("bash" ,bash)
- ("coreutils" ,coreutils)))
- (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
- (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
-Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
-like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
- (home-page "https://github.com/vinceliuice/matcha")
- (license license:gpl3+)))
-
(define-public arc-icon-theme
(package
(name "arc-icon-theme")
@@ -220,6 +174,37 @@ simple and consistent.")
(license (list license:gpl3+
license:cc-by-sa4.0))))
+(define-public papirus-icon-theme
+ (package
+ (name "papirus-icon-theme")
+ (version "20210101")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme")
+ (commit version)))
+ (sha256
+ (base32
+ "0w6qg3zjhfvjg1gg5inranf8ianb4mrp0jm9qgi6hg87ig1rashs"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (delete 'build))))
+ (native-inputs
+ `(("gtk+:bin" ,gtk+ "bin")))
+ (home-page "https://git.io/papirus-icon-theme")
+ (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
+ (description "Papirus is a fork of the icon theme Paper with a lot of new icons
+and a few extra features.")
+ (license license:gpl3)))
+
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")
@@ -684,6 +669,52 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
Shimmer Project. It supports GNOME, Unity, and Xfce.")
(license (list license:gpl2+ license:cc-by-sa3.0))))
+(define-public matcha-theme
+ (package
+ (name "matcha-theme")
+ (version "2021-01-01")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vinceliuice/Matcha-gtk-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pa6ra87wlq0gwz4n03l6xv0pxiamr5dygycvppms8v6xyc2aa0r"))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (source (assoc-ref %build-inputs "source"))
+ (bash (assoc-ref %build-inputs "bash"))
+ (coreutils (assoc-ref %build-inputs "coreutils"))
+ (themesdir (string-append out "/share/themes")))
+ (setenv "PATH"
+ (string-append coreutils "/bin:"
+ (string-append bash "/bin:")))
+ (copy-recursively source (getcwd))
+ (patch-shebang "install.sh")
+ (mkdir-p themesdir)
+ (invoke "./install.sh" "-d" themesdir)
+ #t))))
+ (inputs
+ `(("gtk-engines" ,gtk-engines)))
+ (native-inputs
+ `(("bash" ,bash)
+ ("coreutils" ,coreutils)))
+ (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
+ (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
+Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
+like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
+ (home-page "https://github.com/vinceliuice/matcha")
+ (license license:gpl3+)))
+
(define-public numix-gtk-theme
(package
(name "numix-gtk-theme")
@@ -722,37 +753,6 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(define-public numix-theme
(deprecated-package "numix-theme" numix-gtk-theme))
-(define-public papirus-icon-theme
- (package
- (name "papirus-icon-theme")
- (version "20210101")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme")
- (commit version)))
- (sha256
- (base32
- "0w6qg3zjhfvjg1gg5inranf8ianb4mrp0jm9qgi6hg87ig1rashs"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f
- #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure)
- (delete 'build))))
- (native-inputs
- `(("gtk+:bin" ,gtk+ "bin")))
- (home-page "https://git.io/papirus-icon-theme")
- (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
- (description "Papirus is a fork of the icon theme Paper with a lot of new icons
-and a few extra features.")
- (license license:gpl3)))
-
(define-public vala-language-server
(package
(name "vala-language-server")