summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-03 00:11:53 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-07 19:34:23 +0100
commit43c8b56f72e03ec041238283d05b8d533bc40723 (patch)
tree3f596a92d0d1aff8279e0b17e5eed788b8af480b /gnu/packages/gnome-xyz.scm
parent7ae52dd04f67a215be6d5bfc3135a3baad0a7c13 (diff)
downloadguix-patches-43c8b56f72e03ec041238283d05b8d533bc40723.tar
guix-patches-43c8b56f72e03ec041238283d05b8d533bc40723.tar.gz
gnu: Move faba-icon-theme and moka-icon-theme to gnome-xyz.scm
They need to be moved together, as the latter inherits the former. * gnu/packages/gnome.scm (faba-icon-theme, moka-icon-theme): Move from here... * gnu/packages/gnome-xyz.scm (faba-icon-theme, moka-icon-theme): ... to here.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0477ccfbaf..0c76c6320d 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -164,6 +164,62 @@ which haven't been updated for some years. The new app icons are ported from
the Obsidian icon theme.")
(license license:gpl3)))
+(define-public faba-icon-theme
+ (package
+ (name "faba-icon-theme")
+ (version "4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/snwh/faba-icon-theme")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xh6ppr73p76z60ym49b4d0liwdc96w41cc5p07d48hxjsa6qd6n"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'disable-post-install
+ (lambda _
+ (substitute* "meson.build"
+ (("meson.add_install_script.*") "")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Faba icon theme")
+ (description
+ "Faba is a minimal icon set used as a basis for other themes such as
+Moka")
+ (home-page "https://snwh.org/moka")
+ (license (list license:lgpl3+
+ license:cc-by-sa4.0))))
+
+(define-public moka-icon-theme
+ (package
+ (inherit faba-icon-theme)
+ (name "moka-icon-theme")
+ (version "5.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/snwh/moka-icon-theme")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "015l02im4mha5z91dbchxf6xkp66d346bg3xskwg0rh3lglhjsrd"))))
+ (propagated-inputs
+ ;; Moka is based on Faba by using it as a fallback icon set instead of
+ ;; bundling it, so we need to add it as a propagated input.
+ `(("faba-icon-theme" ,faba-icon-theme)))
+ (synopsis "Moka icon theme")
+ (description "Moka is a stylized desktop icon set, designed to be clear,
+simple and consistent.")
+ (license (list license:gpl3+
+ license:cc-by-sa4.0))))
+
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")