summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-03 00:01:13 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-07 19:34:21 +0100
commit7ae52dd04f67a215be6d5bfc3135a3baad0a7c13 (patch)
tree4810e9d5fccc76606a023887271aff63141859d2 /gnu/packages/gnome-xyz.scm
parent364bc7a01b2fe41410c684b1f3c8c825085d7d1f (diff)
downloadguix-patches-7ae52dd04f67a215be6d5bfc3135a3baad0a7c13.tar
guix-patches-7ae52dd04f67a215be6d5bfc3135a3baad0a7c13.tar.gz
gnu: arc-icon-theme: Move to gnome-xyz.
* gnu/packages/gnome.scm (arc-icon-theme): Move from here... * gnu/packages/gnome-xyz.scm (arc-icon-theme): ... to here.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4539cddbfb..0477ccfbaf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -96,6 +96,41 @@ like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
(home-page "https://github.com/vinceliuice/matcha")
(license license:gpl3+)))
+(define-public arc-icon-theme
+ (package
+ (name "arc-icon-theme")
+ (version "20161122")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/horst3180/arc-icon-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ch3hp08qri93510hypzz6m2x4xgg2h15wvnhjwh1x1s1b7jvxjd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-configure-during-bootstrap
+ (lambda _
+ (substitute* "autogen.sh"
+ (("^\"\\$srcdir/configure\".*") ""))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ ;; When Arc is missing an icon, it looks in the Moka icon theme for it.
+ (propagated-inputs
+ `(("moka-icon-theme" ,moka-icon-theme)))
+ (synopsis "Arc icon theme")
+ (description "The Arc icon theme provides a set of icons matching the
+style of the Arc GTK theme. Icons missing from the Arc theme are provided by
+the Moka icon theme.")
+ (home-page "https://github.com/horst3180/arc-icon-theme")
+ (license license:gpl3+)))
+
(define-public delft-icon-theme
(package
(name "delft-icon-theme")