summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-11-07 10:22:02 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-08 22:30:40 +0100
commit34bcfae26eae67e13d29c3b08a90c43ccab0c054 (patch)
treee3a8f2f54b99fc41257d62ce9eb7a4df6ea12bcc /gnu/packages/gnome-xyz.scm
parent0f0bffc4bd054336b977f765897508716a3d1d60 (diff)
downloadguix-patches-34bcfae26eae67e13d29c3b08a90c43ccab0c054.tar
guix-patches-34bcfae26eae67e13d29c3b08a90c43ccab0c054.tar.gz
gnu: Add gnome-shell-extension-noannoyance.
* gnu/packages/gnome-xyz: (gnome-shell-extension-noannoyance): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 3131ed662a..8c45b552e8 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -95,3 +95,34 @@ overview, transforming it into a dock for easier application launching and
faster window switching.")
(home-page "https://micheleg.github.io/dash-to-dock/")
(license license:gpl2+)))
+
+(define-public gnome-shell-extension-noannoyance
+ (package
+ (name "gnome-shell-extension-noannoyance")
+ (version "5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BjoernDaase/noannoyance.git")
+ (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
+ (sha256
+ (base32
+ "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
+ (file-name (git-file-name name version))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((dst (string-append
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions/"
+ "noannoyance@daase.net")))
+ (mkdir-p dst)
+ (copy-recursively (assoc-ref %build-inputs "source") dst)))))
+ (synopsis "Removes 'Window is ready' annotation")
+ (description "One of the many extensions, that remove this message.
+It uses ES6 syntax and claims to be more actively maintained than others.")
+ (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+ (license license:gpl2)))