summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-11-07 19:20:44 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-08 22:30:37 +0100
commit0f0bffc4bd054336b977f765897508716a3d1d60 (patch)
tree058514b2aac2842dfcb64059b9305bd3e1d0f60c /gnu/packages/gnome-xyz.scm
parentb26a239c70cab928457e0f9a6da2a2cb89089629 (diff)
downloadguix-patches-0f0bffc4bd054336b977f765897508716a3d1d60.tar
guix-patches-0f0bffc4bd054336b977f765897508716a3d1d60.tar.gz
gnu: Add gnome-shell-extension-dash-to-dock.
* gnu/packages/gnome-xyz.scm: (gnome-shell-extension-dash-to-dock): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 1981431b60..3131ed662a 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -58,3 +58,40 @@ date app icons. It will stay optically close to the original Faenza icons,
which haven't been updated for some years. The new app icons are ported from
the Obsidian icon theme.")
(license license:gpl3)))
+
+(define-public gnome-shell-extension-dash-to-dock
+ (package
+ (name "gnome-shell-extension-dash-to-dock")
+ (version "65")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/micheleg/dash-to-dock.git")
+ (commit (string-append "extensions.gnome.org-v"
+ version))))
+ (sha256
+ (base32
+ "0ln49l9s0yfl30pi77pz7xlmh63l9vjppi863kry5lay10dsvz47"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "INSTALLBASE="
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("glib" ,glib "bin")))
+ (synopsis "Transforms GNOME's dash into a dock")
+ (description "This extension moves the dash out of the
+overview, transforming it into a dock for easier application launching and
+faster window switching.")
+ (home-page "https://micheleg.github.io/dash-to-dock/")
+ (license license:gpl2+)))