summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-11-07 10:16:19 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-08 22:26:16 +0100
commitb26a239c70cab928457e0f9a6da2a2cb89089629 (patch)
tree82959ac4fc1fccad170cf5a7b237b3bd6ef8e47e /gnu/packages/gnome-xyz.scm
parentf59ea3a746dde89652df4e0278fbbfe669744d2a (diff)
downloadguix-patches-b26a239c70cab928457e0f9a6da2a2cb89089629.tar
guix-patches-b26a239c70cab928457e0f9a6da2a2cb89089629.tar.gz
gnu: Add delft-icon-theme.
* /gnu/packages/gnome-xyz.scm: New file. (delft-icon-theme): New variable. * /gnu/local.mk: Add it. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
new file mode 100644
index 0000000000..1981431b60
--- /dev/null
+++ b/gnu/packages/gnome-xyz.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gnome-xyz)
+ #:use-module (guix build-system trivial)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config))
+
+(define-public delft-icon-theme
+ (package
+ (name "delft-icon-theme")
+ (version "1.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/madmaxms/iconpack-delft.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
+ (file-name (git-file-name name version))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (copy-recursively (assoc-ref %build-inputs "source") "icons")
+ (delete-file "icons/README.md")
+ (delete-file "icons/LICENSE")
+ (delete-file "icons/logo.jpg")
+ (copy-recursively "icons" (string-append %output "/share/icons")))))
+ (home-page "https://www.gnome-look.org/p/1199881/")
+ (synopsis "Continuation of Faenza icon theme with up to date app icons")
+ (description "Delft is a fork of the popular icon theme Faenza with up to
+date app icons. It will stay optically close to the original Faenza icons,
+which haven't been updated for some years. The new app icons are ported from
+the Obsidian icon theme.")
+ (license license:gpl3)))