summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-01-11 15:26:11 -0600
committerMathieu Othacehe <othacehe@gnu.org>2022-01-12 12:52:33 +0100
commit027973721b964cef3441edf2cb7738257b36b962 (patch)
tree1ce9b57fa00c4ce88eb901bbc9b24ec91e3c3556 /gnu/packages/gnome-xyz.scm
parent979328fb618153dbc9bb7b0cccb3464757ae4fc1 (diff)
downloadguix-patches-027973721b964cef3441edf2cb7738257b36b962.tar
guix-patches-027973721b964cef3441edf2cb7738257b36b962.tar.gz
gnu: gnome-xyz: Add gnome-shell-extension-jiggle.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-jiggle): New Variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 9b8b820484..64f1f6e436 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -782,6 +782,48 @@ Gnome overview with something that resembles the old vertically oriented
style.")
(license license:gpl3)))
+(define-public gnome-shell-extension-jiggle
+ (package
+ (name "gnome-shell-extension-jiggle")
+ (version "8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeffchannell/jiggle/")
+ (commit version)))
+ (sha256
+ (base32
+ "1wbdx2bp22bdwj51ckgivwglkmckr7z8kfwvc8nv4y376hjz5jxz"))
+ (file-name (git-file-name name version))
+ (snippet
+ '(begin (delete-file "schemas/gschemas.compiled")))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." ,(string-append
+ "share/gnome-shell/extensions/"
+ "jiggle@jeffchannell.com")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ (lambda _
+ (substitute* "metadata.json"
+ (("\"40.0\"") "\"40\", \"41\""))))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs
+ (list `(,glib "bin"))) ; for glib-compile-resources
+ (home-page "https://github.com/jeffchannell/jiggle")
+ (synopsis "Mouse cursor enlargment for small and fast movements")
+ (description "Jiggle is a Gnome Shell extension that highlights the cursor
+position when the mouse is moved rapidly.")
+ (license license:gpl2)))
+
(define-public arc-theme
(package
(name "arc-theme")