summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-01-11 15:24:08 -0600
committerMathieu Othacehe <othacehe@gnu.org>2022-01-12 12:52:30 +0100
commit979328fb618153dbc9bb7b0cccb3464757ae4fc1 (patch)
tree51f3bbd6eb942d52ab4c39da4202a99f4f3714ed /gnu/packages/gnome-xyz.scm
parent2d3bec89b5f7d4dcdfc78a404a06d27639eec83d (diff)
downloadguix-patches-979328fb618153dbc9bb7b0cccb3464757ae4fc1.tar
guix-patches-979328fb618153dbc9bb7b0cccb3464757ae4fc1.tar.gz
gnu: gnome-xyz: Add gnome-shell-extension-vertical-overview.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vertical-overview): New Variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 299dd65882..9b8b820484 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Attila Lendvai <attila@lendvai.name>
+;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -742,6 +743,45 @@ store an history of everything you do, so that you can get back to older
copies you now want to paste.")
(license license:bsd-2)))
+(define-public gnome-shell-extension-vertical-overview
+ (package
+ (name "gnome-shell-extension-vertical-overview")
+ (version "8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RensAlthuis/vertical-overview")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "01vz48p3bh7p3ybdyw0s0ahs18lk2kzk9x4ad46s0dnwmmsyhww9"))
+ (file-name (git-file-name name version))
+ (snippet
+ '(begin (delete-file "schemas/gschemas.compiled")))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." ,(string-append
+ "share/gnome-shell/extensions/"
+ "vertical-overview@RensAlthuis.github.com")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs
+ (list `(,glib "bin"))) ; for glib-compile-resources
+ (home-page "https://github.com/RensAlthuis/vertical-overview")
+ (synopsis "Provides a vertical overview in Gnome 40 and upper")
+ (description "This Gnome extension replaces the new horizontally oriented
+Gnome overview with something that resembles the old vertically oriented
+style.")
+ (license license:gpl3)))
+
(define-public arc-theme
(package
(name "arc-theme")