summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 09:39:52 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 20:51:43 -0400
commit32d00992be41603b4972f555273d27a7a6732c7d (patch)
treeef3c03b5d2913a175ffbc5003688a7198cce4aab /gnu/packages/glib.scm
parentfdf32982f50d9556367559d414bf1ffea9650ea4 (diff)
downloadguix-patches-32d00992be41603b4972f555273d27a7a6732c7d.tar
guix-patches-32d00992be41603b4972f555273d27a7a6732c7d.tar.gz
gnu: glib-with-documentation: Fix documentation build.
* gnu/packages/glib.scm (glib-with-documentation) [native-inputs]: Add docbook-4.2. Remove libxml2. [arguments]<#:phases>['patch-docbook-xml]: New phase. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 01bdcefb04..36cb3ed3c7 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -321,7 +321,8 @@ functions for strings and common data structures.")
(properties (alist-delete 'hidden? (package-properties glib)))
(outputs (cons "doc" (package-outputs glib))) ; 20 MiB of GTK-Doc reference
(native-inputs
- `(("docbook-xml" ,docbook-xml)
+ `(("docbook-xml-4.2" ,docbook-xml-4.2)
+ ("docbook-xml-4.5" ,docbook-xml)
("gtk-doc" ,gtk-doc) ; for the doc
("libxml2" ,libxml2)
,@(package-native-inputs glib)))
@@ -331,6 +332,17 @@ functions for strings and common data structures.")
`(cons "-Dgtk_doc=true" ,flags))
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "docs"
+ (substitute* (find-files "." "\\.xml$")
+ (("http://www.oasis-open.org/docbook/xml/4\\.5/")
+ (string-append (assoc-ref inputs "docbook-xml-4.5")
+ "/xml/dtd/docbook/"))
+ (("http://www.oasis-open.org/docbook/xml/4\\.2/")
+ (string-append (assoc-ref inputs "docbook-xml-4.2")
+ "/xml/dtd/docbook/"))))
+ #t))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))