summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 09:37:00 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 20:51:42 -0400
commitfdf32982f50d9556367559d414bf1ffea9650ea4 (patch)
treed8ad7aaf6c0693ff5ab2ce701d6e4a7a82b0bc30 /gnu/packages/glib.scm
parent884e2c6830f26e27070e8486e754c9dfd2f3e921 (diff)
downloadguix-patches-fdf32982f50d9556367559d414bf1ffea9650ea4.tar
guix-patches-fdf32982f50d9556367559d414bf1ffea9650ea4.tar.gz
gnu: glib-with-documentation: Make some cosmetic changes.
* gnu/packages/glib.scm (glib-with-documentation): Make some cosmetic changes. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 24829fa03d..01bdcefb04 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -321,8 +321,8 @@ functions for strings and common data structures.")
(properties (alist-delete 'hidden? (package-properties glib)))
(outputs (cons "doc" (package-outputs glib))) ; 20 MiB of GTK-Doc reference
(native-inputs
- `(("gtk-doc" ,gtk-doc) ; for the doc
- ("docbook-xml" ,docbook-xml)
+ `(("docbook-xml" ,docbook-xml)
+ ("gtk-doc" ,gtk-doc) ; for the doc
("libxml2" ,libxml2)
,@(package-native-inputs glib)))
(arguments
@@ -333,12 +333,13 @@ functions for strings and common data structures.")
`(modify-phases ,phases
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (html (string-append "/share/gtk-doc")))
- (copy-recursively (string-append out html)
- (string-append doc html))
- (delete-file-recursively (string-append out html))
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc"))
+ (html (string-append "/share/gtk-doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out html)
+ (string-append doc html))
#t)))))))))
;;; TODO: Merge into glib as a 'static' output on core-updates.