summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-05 11:23:13 +0200
committerAndreas Enge <andreas@enge.fr>2013-05-05 11:23:13 +0200
commitc5ea1201fbc7dbabe75d61ad3f9b898b7f7e86f5 (patch)
tree1573cc551eb958f12a4f2bd3f71d0e00ea388f24 /gnu/packages/ghostscript.scm
parente0eb886dcee16cb2cb26a0d0b1e73a5b82547c7c (diff)
downloadguix-patches-c5ea1201fbc7dbabe75d61ad3f9b898b7f7e86f5.tar
guix-patches-c5ea1201fbc7dbabe75d61ad3f9b898b7f7e86f5.tar.gz
gnu: Add GNU gv.
* gnu/packages/ghostscript.scm (gv): New variable.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 5b0e4ec6ed..6781ffecdf 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -216,3 +216,29 @@ library.")
Ghostscript. It currently includes the 35 standard PostScript fonts.")
(license license:gpl2)
(home-page "http://sourceforge.net/projects/gs-fonts/")))
+
+(define-public gv
+ (package
+ (name "gv")
+ (version "3.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gv/gv-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
+ (build-system gnu-build-system)
+ (propagated-inputs `(("ghostscript" ,ghostscript)))
+ (inputs `(("libx11" ,libx11)
+ ("libxaw3d" ,libxaw3d)
+ ("libxinerama" ,libxinerama)
+ ("libxpm" ,libxpm)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)))
+ (synopsis "postscript and pdf viewer for x")
+ (description
+ "GNU gv allows to view and navigate through PostScript and PDF documents
+on an X display by providing a graphical user interface for the Ghostscript
+interpreter.")
+ (license license:gpl3+)
+ (home-page "http://www.gnu.org/software/gv/")))