summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-28 06:34:44 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-12 18:13:30 +0200
commit371aa5777a3805a3886f3feea5f1960fe3fe4219 (patch)
tree0526988b47485e2064610d8b8e5347ab9d14551e /gnu/packages/geo.scm
parente159047e3c08c16218adf9202dc817a1fd0e8ccf (diff)
downloadguix-patches-371aa5777a3805a3886f3feea5f1960fe3fe4219.tar
guix-patches-371aa5777a3805a3886f3feea5f1960fe3fe4219.tar.gz
gnu: Add python-geopandas.
* gnu/packages/geo.scm (python-geopandas): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 4f791537c0..f460e08828 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -698,6 +698,47 @@ systems and integrates readily with other Python GIS packages such as
pyproj, Rtree, and Shapely.")
(license license:bsd-3)))
+(define-public python-geopandas
+ (package
+ (name "python-geopandas")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geopandas" version))
+ (sha256
+ (base32
+ "02k389zyyjv51gd09c92vlr83sv46awdq0066jgh5i24vjs2m5v3"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"
+ ; Disable test that fails with
+ ; NotImplementedError in pandas.
+ "-k" "not test_fillna_no_op_returns_copy"
+ ; Disable tests that require internet access.
+ "-m" "not web")))))))
+ (propagated-inputs
+ `(("python-fiona" ,python-fiona)
+ ("python-pandas" ,python-pandas)
+ ("python-pyproj" ,python-pyproj)
+ ("python-shapely" ,python-shapely)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://geopandas.org")
+ (synopsis "Geographic pandas extensions")
+ (description "The goal of GeoPandas is to make working with
+geospatial data in Python easier. It combines the capabilities of
+Pandas and Shapely, providing geospatial operations in Pandas and a
+high-level interface to multiple geometries to Shapely. GeoPandas
+enables you to easily do operations in Python that would otherwise
+require a spatial database such as PostGIS.")
+ (license license:bsd-3)))
+
(define-public mapnik
(package
(name "mapnik")