summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-28 06:34:43 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-12 18:13:30 +0200
commite159047e3c08c16218adf9202dc817a1fd0e8ccf (patch)
tree264fc71db6b1aeeea74ee7629207f5ef226fd680 /gnu/packages/geo.scm
parent436b049c2458dbd8cc358fb8e4ad7dc6d6c8191d (diff)
downloadguix-patches-e159047e3c08c16218adf9202dc817a1fd0e8ccf.tar
guix-patches-e159047e3c08c16218adf9202dc817a1fd0e8ccf.tar.gz
gnu: Add python-fiona.
* gnu/packages/geo.scm (python-fiona): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index cd9702ac94..4f791537c0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -641,6 +641,63 @@ projections.")
projections and coordinate transformations library.")
(license license:expat)))
+(define-public python-fiona
+ (package
+ (name "python-fiona")
+ (version "1.8.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Fiona" version))
+ (sha256
+ (base32
+ "0fql7i7dg1xpbadmk8d26dwp91v7faixxc4wq14zg0kvhp9041d7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-local-fiona
+ (lambda _
+ ; This would otherwise interfere with finding the installed
+ ; fiona when running tests.
+ (delete-file-recursively "fiona")))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (when tests?
+ (invoke "pytest" "-m" "not network and not wheel")))))))
+ (inputs
+ `(("gdal" ,gdal)))
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-certifi" ,python-certifi)
+ ("python-click" ,python-click)
+ ("python-click-plugins" ,python-click-plugins)
+ ("python-cligj" ,python-cligj)
+ ("python-munch" ,python-munch)
+ ("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)
+ ("python-pytz" ,python-pytz)))
+ (native-inputs
+ `(("gdal" ,gdal) ; for gdal-config
+ ("python-boto3" ,python-boto3)
+ ("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/Toblerity/Fiona")
+ (synopsis
+ "Fiona reads and writes spatial data files")
+ (description
+ "Fiona is GDAL’s neat and nimble vector API for Python programmers.
+Fiona is designed to be simple and dependable. It focuses on reading
+and writing data in standard Python IO style and relies upon familiar
+Python types and protocols such as files, dictionaries, mappings, and
+iterators instead of classes specific to OGR. Fiona can read and write
+real-world data using multi-layered GIS formats and zipped virtual file
+systems and integrates readily with other Python GIS packages such as
+pyproj, Rtree, and Shapely.")
+ (license license:bsd-3)))
+
(define-public mapnik
(package
(name "mapnik")