summaryrefslogtreecommitdiff
path: root/gnu/packages/genimage.scm
diff options
context:
space:
mode:
authorRyan Sundberg <ryan@arctype.co>2021-11-04 01:35:10 -0700
committerMathieu Othacehe <othacehe@gnu.org>2021-11-12 12:02:32 +0000
commit39754503e83f5f50ee25a2bcbac41d5bc436f7aa (patch)
tree69880cb532add2fd2356feda7f8af49d39f1ace3 /gnu/packages/genimage.scm
parent6e67c701a88064babd1aef93b58890aed2dcd0aa (diff)
downloadguix-patches-39754503e83f5f50ee25a2bcbac41d5bc436f7aa.tar
guix-patches-39754503e83f5f50ee25a2bcbac41d5bc436f7aa.tar.gz
gnu: genimage: Update to 14.
Update genimage from version 11 to 14. A patch is required for the tests due to differences in ext tooling. * gnu/local.mk (dist_patch_DATA): Replace patch reference. * gnu/packages/genimage.scm: Update package source. * gnu/packages/patches/genimage-mke2fs-test.patch: New patch file. * gnu/packages/patches/genimage-signedness.patch: Delete obsolete patch. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/genimage.scm')
-rw-r--r--gnu/packages/genimage.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index fb994231dd..f5574b04ee 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -43,7 +43,7 @@
(define-public genimage
(package
(name "genimage")
- (version "11")
+ (version "14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -52,9 +52,9 @@
(file-name (git-file-name name version))
(sha256
(base32
- "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
- ;; will be shipped with release 14
- (patches (search-patches "genimage-signedness.patch"))))
+ "1l45djpbaffhyw0allq3mgzwrdilk05iyj0nvp8l3s47vnp5bnbs"))
+ (patches
+ (search-patches "genimage-mke2fs-test.patch"))))
(build-system gnu-build-system)
(arguments
`(#:modules