summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Sundberg <ryan@arctype.co>2021-11-04 01:35:10 -0700
committerMathieu Othacehe <othacehe@gnu.org>2021-11-12 12:02:32 +0000
commit39754503e83f5f50ee25a2bcbac41d5bc436f7aa (patch)
tree69880cb532add2fd2356feda7f8af49d39f1ace3 /gnu
parent6e67c701a88064babd1aef93b58890aed2dcd0aa (diff)
downloadguix-patches-39754503e83f5f50ee25a2bcbac41d5bc436f7aa.tar
guix-patches-39754503e83f5f50ee25a2bcbac41d5bc436f7aa.tar.gz
gnu: genimage: Update to 14.
Update genimage from version 11 to 14. A patch is required for the tests due to differences in ext tooling. * gnu/local.mk (dist_patch_DATA): Replace patch reference. * gnu/packages/genimage.scm: Update package source. * gnu/packages/patches/genimage-mke2fs-test.patch: New patch file. * gnu/packages/patches/genimage-signedness.patch: Delete obsolete patch. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/genimage.scm8
-rw-r--r--gnu/packages/patches/genimage-mke2fs-test.patch40
-rw-r--r--gnu/packages/patches/genimage-signedness.patch24
4 files changed, 45 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 05258ac054..208875754b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1128,7 +1128,7 @@ dist_patch_DATA = \
%D%/packages/patches/gdk-pixbuf-CVE-2020-29385.patch \
%D%/packages/patches/gdm-default-session.patch \
%D%/packages/patches/geary-CVE-2020-24661.patch \
- %D%/packages/patches/genimage-signedness.patch \
+ %D%/packages/patches/genimage-mke2fs-test.patch \
%D%/packages/patches/geoclue-config.patch \
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
%D%/packages/patches/ghc-testsuite-dlopen-pie.patch \
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index fb994231dd..f5574b04ee 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -43,7 +43,7 @@
(define-public genimage
(package
(name "genimage")
- (version "11")
+ (version "14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -52,9 +52,9 @@
(file-name (git-file-name name version))
(sha256
(base32
- "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
- ;; will be shipped with release 14
- (patches (search-patches "genimage-signedness.patch"))))
+ "1l45djpbaffhyw0allq3mgzwrdilk05iyj0nvp8l3s47vnp5bnbs"))
+ (patches
+ (search-patches "genimage-mke2fs-test.patch"))))
(build-system gnu-build-system)
(arguments
`(#:modules
diff --git a/gnu/packages/patches/genimage-mke2fs-test.patch b/gnu/packages/patches/genimage-mke2fs-test.patch
new file mode 100644
index 0000000000..c4a17590f2
--- /dev/null
+++ b/gnu/packages/patches/genimage-mke2fs-test.patch
@@ -0,0 +1,40 @@
+diff --git a/test/mke2fs.dump b/test/mke2fs.dump
+index 8e63662..0c25798 100644
+--- a/test/mke2fs.dump
++++ b/test/mke2fs.dump
+@@ -11,7 +11,7 @@ Filesystem OS type: Linux
+ Inode count: 8192
+ Block count: 32768
+ Reserved block count: 1638
+-Free blocks: 26568
++Free blocks: 26566
+ Free inodes: 8141
+ First block: 1
+ Block size: 1024
+@@ -29,7 +29,7 @@ Mount count: 0
+ Maximum mount count: -1
+ Last checked: Sat Jan 1 00:00:00 2000
+ Check interval: 0 (<none>)
+-Lifetime writes: 141 kB
++Lifetime writes: 143 kB
+ Reserved blocks uid: 0 (user root)
+ Reserved blocks gid: 0 (group root)
+ First inode: 11
+@@ -49,13 +49,13 @@ Journal sequence: 0x00000001
+ Journal start: 0
+
+
+-Group 0: (Blocks 1-8192) csum 0x74a0 [ITABLE_ZEROED]
++Group 0: (Blocks 1-8192) csum 0x3f30 [ITABLE_ZEROED]
+ Primary superblock at 1, Group descriptors at 2-2
+- Block bitmap at 3 (+2), csum 0x16cec4db
++ Block bitmap at 3 (+2), csum 0x8d67cdef
+ Inode bitmap at 7 (+6), csum 0xb1052088
+ Inode table at 11-522 (+10)
+- 6093 free blocks, 1997 free inodes, 18 directories, 1997 unused inodes
+- Free blocks: 2100-8192
++ 6091 free blocks, 1997 free inodes, 18 directories, 1997 unused inodes
++ Free blocks: 2102-8192
+ Free inodes: 52-2048
+ Group 1: (Blocks 8193-16384) csum 0x8fde [INODE_UNINIT, BLOCK_UNINIT, ITABLE_ZEROED]
+ Backup superblock at 8193, Group descriptors at 8194-8194
diff --git a/gnu/packages/patches/genimage-signedness.patch b/gnu/packages/patches/genimage-signedness.patch
deleted file mode 100644
index 2204dfb545..0000000000
--- a/gnu/packages/patches/genimage-signedness.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
-Author: Timotej Lazar <timotej.lazar@araneo.si>
-Date: Wed Aug 19 19:36:02 2020 +0200
-
- test: normalize flags reported by dumpe2fs
-
- Filesystem flags depend on the system – usually signed_directory_hash,
- but unsigned_directory_hash at least on arm64.
-
- Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
-
-diff --git a/test/basic-images.test b/test/basic-images.test
-index f6685e1..cb104c3 100755
---- a/test/basic-images.test
-+++ b/test/basic-images.test
-@@ -158,6 +158,8 @@ check_ext() {
- # format change
- csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
- dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
-+ # some architectures (including arm64) use unsigned char
-+ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
- # fixup for ext3 journal size with old tune2fs
- sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
- # output format changed with some version