summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorguy fleury iteriteka <gfleury@disroot.org>2020-07-16 16:33:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-07-19 20:23:00 +0300
commit163686d82e9afeaae45235eb61ae5ee77d4b16b7 (patch)
treee987821a9cc7192c1626c5d63f0d5e2a00fa5c52 /gnu/packages/gcc.scm
parentdc9e8f2ed3cc568969e351f8bad84a6b36dacac6 (diff)
downloadguix-patches-163686d82e9afeaae45235eb61ae5ee77d4b16b7.tar
guix-patches-163686d82e9afeaae45235eb61ae5ee77d4b16b7.tar.gz
gnu: Add gdc-10.
* gnu/packages/gcc.scm (gdc-10): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9e881092c9..9ff5e3d7c0 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -692,6 +692,11 @@ as the 'native-search-paths' field."
(custom-gcc gcc "gfortran" '("fortran")
%generic-search-paths)))
+(define-public gdc-10
+ (hidden-package
+ (custom-gcc gcc-10 "gdc" '("d")
+ %generic-search-paths)))
+
(define-public libgccjit
(package
(inherit gcc-9)