summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-05-02 14:41:12 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-03 18:26:49 +0200
commitfa7dc25c2faa4769b3a053a41bb251dcc1233305 (patch)
tree2523f696f4394aee975176906318b326a43d7dc3 /gnu/packages/games.scm
parent55b6e1a7ada24221d7241c91ae1cca84fd22fcc9 (diff)
downloadguix-patches-fa7dc25c2faa4769b3a053a41bb251dcc1233305.tar
guix-patches-fa7dc25c2faa4769b3a053a41bb251dcc1233305.tar.gz
gnu: pioneers: Patch path to beep.
Fixes <https://issues.guix.gnu.org/47131> * gnu/packages/games.scm (pioneers): Patch path to beep. [inputs]: Add beep. [arguments]: Add phase patch-beep-path. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8bd3c95ebb..f12f2bc53d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4711,7 +4711,18 @@ are only two levels to play with, but they are very addictive.")
(base32
"07b3xdd81n8ybsb4fzc5lx0813y9crzp1hj69khncf4faj48sdcs"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Fixes https://issues.guix.gnu.org/47131.
+ (add-after 'unpack 'patch-beep-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "client/gtk/audio.c"
+ (("\"beep\"")
+ (string-append "\"" (assoc-ref inputs "beep") "/bin/beep\"")))
+ #t)))))
(inputs `(("avahi" ,avahi)
+ ("beep" ,beep)
("gtk+" ,gtk+)
("librsvg" ,librsvg)))
(native-inputs `(("intltool" ,intltool)