summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2021-05-02 13:46:20 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-03 18:26:49 +0200
commit55b6e1a7ada24221d7241c91ae1cca84fd22fcc9 (patch)
treeb42bbe58c04ecc7abc460f3ec3397eece8f674cd /gnu/packages/games.scm
parentd94e9cb774fee87dc642c363df70f0461a55fbd5 (diff)
downloadguix-patches-55b6e1a7ada24221d7241c91ae1cca84fd22fcc9.tar
guix-patches-55b6e1a7ada24221d7241c91ae1cca84fd22fcc9.tar.gz
gnu: xboard: Patch path to aplay.
Fixes <http://issues.guix.gnu.org/47195>. * gnu/packages/games.scm (xboard): Patch path to aplay. [inputs]: Add alsa-utils. [arguments]: Add phase patch-aplay-path. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..8bd3c95ebb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3323,8 +3323,19 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(base32
"1mkh36xnnacnz9r00b5f9ld9309k32jv6mcavklbdnca8bl56bib"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Fixes https://issues.guix.gnu.org/47195.
+ (add-after 'unpack 'patch-aplay-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "xboard.conf"
+ (("aplay -q")
+ (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))
+ #t)))))
(inputs
- `(("gtk+" ,gtk+-2)
+ `(("alsa-utils" ,alsa-utils)
+ ("gtk+" ,gtk+-2)
("librsvg" ,librsvg)))
(native-inputs
`(("texinfo" ,texinfo)