summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-10 14:59:58 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-10 15:05:55 +0100
commit814091efe2e36d83f10b874afe3f6da56ff34e4b (patch)
tree311c61ff3bde5590182a33204a2700d8da0b767b /gnu/packages/games.scm
parentd8cae6cf82c8c61138f5d835d0f3f81f54d70d9c (diff)
downloadguix-patches-814091efe2e36d83f10b874afe3f6da56ff34e4b.tar
guix-patches-814091efe2e36d83f10b874afe3f6da56ff34e4b.tar.gz
gnu: Add stockfish.
* gnu/packages/games.scm (stockfish): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1539a9cbcd..c23f624251 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9870,3 +9870,41 @@ collection of chess games in many ways: browse, edit, add, organize, analyze,
etc. You can also play games on FICS or against an engine.")
(home-page "http://chessx.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public stockfish
+ (package
+ (name "stockfish")
+ (version "11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/official-stockfish/Stockfish.git")
+ (commit (string-append "sf_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12mppipinymj8s1ipq9a7is453vncly49c32ym9wvyklsgyxfzlk"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list "-C" "src"
+ "build"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "ARCH="
+ ,(match (%current-system)
+ ("x86_64-linux" "x86-64")
+ ("i686-linux" "x86-32")
+ ("aarch64-linux" "general-64")
+ ("armhf-linux" "armv7")
+ ("mips64el-linux" "general-64")
+ (_ "general-32"))))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Strong chess engine")
+ (description
+ "Stockfish is a very strong chess engines. It is much stronger than the
+best human chess grandmasters. It can be used with UCI-compatible GUIs like
+ChessX.")
+ (home-page "https://stockfishchess.org/")
+ (license license:gpl3+)))