summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-10 14:06:31 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-10 15:05:55 +0100
commitd8cae6cf82c8c61138f5d835d0f3f81f54d70d9c (patch)
tree0282c4ce2edf9d4b4c473b70309d13930534145d /gnu/packages/games.scm
parent2035134bff2f03948b2d17ce454cc7c7787b3c79 (diff)
downloadguix-patches-d8cae6cf82c8c61138f5d835d0f3f81f54d70d9c.tar
guix-patches-d8cae6cf82c8c61138f5d835d0f3f81f54d70d9c.tar.gz
gnu: Add chessx.
* gnu/packages/games.scm (chessx): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e82c3c44b6..1539a9cbcd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9818,3 +9818,55 @@ challenges.")
and chess engines.")
(home-page "https://www.bergo.eng.br/eboard/")
(license license:gpl2+)))
+
+(define-public chessx
+ (package
+ (name "chessx")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/chessx/chessx/"
+ version "/chessx-" version ".tgz"))
+ (sha256
+ (base32 "09rqyra28w3z9ldw8sx07k5ap3sjlli848p737maj7c240rasc6i"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtsvg" ,qtsvg)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "chessx.pro"
+ (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
+ (string-append (assoc-ref inputs "qttools") "/bin/lrelease")))
+ #t))
+ (add-after 'fix-paths 'make-qt-deterministic
+ (lambda _
+ (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
+ #t))
+ (replace 'configure
+ (lambda _
+ (invoke "qmake")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "release/chessx" (string-append out "/bin"))
+ (install-file "unix/chessx.desktop"
+ (string-append out "/share/applications")))
+ #t)))))
+ (synopsis "Chess game database")
+ (description
+ "ChessX is a chess database. With ChessX you can operate on your
+collection of chess games in many ways: browse, edit, add, organize, analyze,
+etc. You can also play games on FICS or against an engine.")
+ (home-page "http://chessx.sourceforge.net/")
+ (license license:gpl2+)))