summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-25 11:14:52 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-25 11:14:52 +0200
commit80aeefd517b1355ccd1accb09f0d998d84436beb (patch)
treea76a8b8c4835498093aadf2470ea5dac5d79a52f /gnu/packages/game-development.scm
parent744fe9ee259e1e7635f0ef699dcff2662f6894d1 (diff)
downloadguix-patches-80aeefd517b1355ccd1accb09f0d998d84436beb.tar
guix-patches-80aeefd517b1355ccd1accb09f0d998d84436beb.tar.gz
gnu: love-nuklear: Install to lib/love.
* gnu/packages/game-development.scm (love-nuklear)[#:phases]: Add ‘patch-cmake’ phase to change install destination.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 41de1fe722..06bf4041df 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -840,7 +840,13 @@ programming language.")
(build-system cmake-build-system)
(arguments
`(#:build-type "Release"
- #:tests? #f))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cmake
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION .") "DESTINATION lib/love")))))))
(inputs
`(("luajit" ,luajit)))
(synopsis "Lightweight immediate mode GUI for LÖVE games")