summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-25 11:14:33 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-25 11:14:33 +0200
commit744fe9ee259e1e7635f0ef699dcff2662f6894d1 (patch)
treecfe4f5cac54103447462d4965b44d86b6580cd0f /gnu/packages/game-development.scm
parent8a3bcbec8bd1cbd1faa3eed8154ba48e5cd6a221 (diff)
downloadguix-patches-744fe9ee259e1e7635f0ef699dcff2662f6894d1.tar
guix-patches-744fe9ee259e1e7635f0ef699dcff2662f6894d1.tar.gz
gnu: love-nuklear: Update to 2.6.1.
* gnu/packages/game-development.scm (love-nuklear): Update to 2.6.1.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm52
1 files changed, 25 insertions, 27 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index eaa3de3f87..41de1fe722 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -822,35 +822,33 @@ programming language.")
(license license:zlib)))
(define-public love-nuklear
- (let ((version "v2.6")
- (commit "fef4e00a602efb16c57ae962850b6e7a01f7a29a"))
- (package
- (name "love-nuklear")
- (version (git-version version "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/keharriso/love-nuklear/")
- (commit commit)
- (recursive? #t)))
- ;; NOTE: the HEAD of the Nuklear git-submodule is at commit
- ;; "adc52d710fe3c87194b99f540c53e82eb75c2521" of Oct 1 2019
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15qmy8mfwkxy2x9rmxs6f9cyvjvwwj6yf78bs863xmc56dmjzzbn"))))
- (build-system cmake-build-system)
- (arguments
- `(#:build-type "Release"
- #:tests? #f))
- (inputs
- `(("luajit" ,luajit)))
- (synopsis "Lightweight immediate mode GUI for LÖVE games")
- (description "LÖVE is a Lua framework for making 2D games. Nuklear
+ (package
+ (name "love-nuklear")
+ (version "2.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/keharriso/love-nuklear/")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ ;; NOTE: the HEAD of the Nuklear git-submodule is at commit
+ ;; "adc52d710fe3c87194b99f540c53e82eb75c2521" of Oct 1 2019
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "090xp5c975155hd1pa7bdssdlawvygs5s6icdkwbyc8il5kg5kgv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:build-type "Release"
+ #:tests? #f))
+ (inputs
+ `(("luajit" ,luajit)))
+ (synopsis "Lightweight immediate mode GUI for LÖVE games")
+ (description "LÖVE is a Lua framework for making 2D games. Nuklear
is a minimal state immediate mode graphical user interface toolkit. This
package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
- (home-page "https://github.com/keharriso/love-nuklear/")
- (license license:expat))))
+ (home-page "https://github.com/keharriso/love-nuklear/")
+ (license license:expat)))
(define-public allegro-4
(package